
LAB 1: 
 

Evaluating Internet Connection Choices 
for a Small Home PC Network 

 
 
 

This lab has been originally designed as supplemental material for 
Prof. Panko’s textbook “Business Data Networks and Telecommunications”. 

 

 
 
 
 
Download and Install Lab Files 
 
1. Click on the following link:  http://www.cse.yorku.ca/course/3213/Home_LAN_3213_2015.zip. 
2. Save the zip file to the desktop. 
3. Double-click the zip file and extract the files to a directory on the desktop. 
4. To add the file to Riverbed Modeler, open Riverbed Modeler Academic Edition. 
5. Select File → Manage Model Files → Add Model Directory. 
6. Select the directory where you unzipped the lab files (on the desktop) and click OK. 
7. In the Confirm Model Directory window select Include all subdirectories. 
 
 
 
Objective 
 
This lab teaches the basics of using Riverbed Modeler network simulator. Riverbed Modeler’s user-friendly 
interface with drag-and-drop features enable students to effectively model, manage, and troubleshoot real-
world network infrastructures. 
 
The goal of this lab is to investigate application performance and capacity planning, by changing the link speed 
between a home LAN and its ISP. 
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Overview 
 
Riverbed Modeler provides a Virtual Network Environment that models the behavior of networks, including its 
routers, switches, protocols, servers, and individual applications. The Virtual Network Environment allows IT 
managers, network and system planners, and operation’s staff to more effectively diagnose difficult problems, 
validate changes before they are implemented, and plan for future scenarios such as traffic growth and 
network failures. Riverbed Modeler eliminates the need to build real test setups to design and evaluate various 
protocols and algorithms, ultimately saving time and money. 
 
To create a network simulation (called a project in Riverbed Modeler), you specify the nodes (computers, 
switches, routers, etc.) in your network, the links between nodes, and the applications that will be running on 
the nodes. 
 
In this exercise, the initial simulation (project) has been built for you. It models a family’s home PC network, 
which has three PCs connected to the Internet for game playing, web browsing, E-mail, audio streaming, and 
FTP (file transfer protocol). Your objective will be to conduct a series of what-if simulations (scenarios) to see 
how performance differs if the family connects to the Internet using 1) a slow modem downloading at 56 kbps, 
2) a cable modem or DSL line downloading at 512 kbps, or 3) a T1 line with download speed of 1.544 Mbps. 
Throughout the exercise you should keep in mind, nevertheless, that higher speed provided by the ISP is 
always associated with higher service cost. 
 
For each scenario, you will set the download speed in the simulation model, run a simulation, and view the 
results. The ultimate goal of this lab is to address the question of whether faster connections are worth higher 
prices for the home network. 
 
 

 
Lab Instructions 
 
Step 1: Open Lab 1 
 
Riverbed Modeler consists of projects and scenarios. Each scenario represents a different what-if analysis 
performed by the users. Scenarios may contain different versions of the same network or models of different 
networks. A project consists of one or more network scenarios. In this lab, you will create 3 different scenarios 
comparing application performance with different connection speeds to the ISP. 
 
1. Start Riverbed Modeler. 
 
2. Select File → Open… In Look in scroll down to the directory Home_LAN_3213_2015, select 
Home_LAN_3213_2015 Riverbed Modeler file. Click Open. 
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Note: If you do not see the project file, then make sure you have downloaded the lab files. Then unzip the file, 
add the unzipped lab files directory by going to File → Manage Model File → Add Model Directory and 
select Home_LAN_3213_2015. The project should now be added. 
 
 

 
 
 
The above picture shows the simulated network. Each of the network’s PCs connects to the family’s 100 Mbps 
Ethernet switch via a UTP connection. The switch connects to the router, also via UTP. A WAN link connects 
the home PC network to the Internet. Three Internet servers provide different services to the client PCs. 
 
Near the top of the figure are two boxes that do not represent physical components: Applications and Profiles. 
The Applications node contains data about the applications used in the network, such as Web browsing. More 
specifically, traffic is associated with each application, so there is a difference between “light Web browsing” 
and “heavy Web browsing.” Internal file service and print service traffic are not shown; these would be too light 
to make a difference in performance because the Internet WAN connection is the weak link in this network. In 
the Profiles icon, different applications are associated with different PCs.  
 
The complete topology of the simulated network is laid out and the attributes for all the objects are 
preconfigured except the link data rate between the Router and the Internet cloud - this is our WAN link. 
 
 
Step 2: Configure the WAN Link to 56 kbps 
 
In your first scenario, you will configure the WAN link as a 56 kbps dial-up line. 
 
1. Right-click on the WAN link and select Edit Attributes. Here we can see the different link attributes. We will 
be changing the data rate attribute of this link. 
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2. Click in the Value field of the data rate attribute and select Edit… 
 
3. Enter 56,000; press Enter and then click OK. 
 

 
 
 
Step 3: Configure and Run the Simulation 
 
To simulate this network, we will use high fidelity discrete event simulation. The model simulates client/server 
application packets, which represent real world network traffic. 

1. Click on the configure/run simulation button.  
 
2. Make sure the Simulation Duration is set to 8 hours to represent a typical day. 
 
3. Click Run, monitor the progress bar as the simulation proceeds. 
 
4. When the simulation completes, Click Close. 
 
 
Step 4: View Results 
 
We can now view various statistics including the web application Response Time experienced by the 
Researcher and the WAN link utilization. Follow the instructions below to view the statistics. 
 
Performance for the WAN link 
 

1. Right-click on the WAN link and select View Results to view the utilization results for this link. 
 

2. In the Object Statistics pane expand point-to-point and select utilization in both directions, as shown 
below. 
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3. Select Stacked Statistics from the pull-down menu on the bottom right-hand corner to see the results in two 
separate plots. 
 
4. Select Show and then click Close in the View Results window. 
 
Performance for PC2 (Researcher PC) 
 

5. Right-click on the PC2 Researcher client and select View Results to view the web Response Time.  
 
6. Expand Client Http and select the first entry - Page Response Time (seconds) <Researcher / Web 
Browsing (Heavy)>. Also make sure that the pull-down menu on the bottom right-hand corner is set to As Is. 
 
7. Select Show and then click Close in the View Results window. 

8. You can use the hide or show all graphs button  to hide/show the graphs. 
 
 
EXERCISE 1 
Your task is to take a screenshot of your own two (sets of) graphs obtained by performing Steps 4.1 to 
4.8, and include them in the final report. You are also required to comment on the obtained graphs, 
i.e. answer the following questions: 
a) How much are the average download and upload utilization on the WAN link in the first obtained 
graph? How do you explain the difference between the two values? 
b) What it the average Response Time experienced by the Researcher in the second obtained 
graph? In your experience in using the Internet and WWW, is this time acceptable?  
 
 
 
Step 5: 512 kbps Scenario 
 
Implement a fast modem connection downloading a 512 kbps. This is realistic throughput for a cable modem or 
DSL line. 
 
1. Select Scenarios → Duplicate Scenario… and name the new scenario as 512K_DSL. 
 
2. Click OK. This creates a copy of the existing scenario. 
 
 
Step 6: Configure the Link to 512 kbps 
 
Right-click on the WAN link, select Edit Attribute, and change the data rate attribute to 512,000. 
 
 
Step 7: Run the 512 kbps Simulation 
 
Rerun the simulation. You can refer to the steps given previously for setting the duration and running the 
simulation. 
 
 
Step 8: View Results for 512 kbps Scenario 
 
Follow the same steps mentioned before to view the link utilization on the WAN link, and Response Time for 
the researcher PC. 
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EXERCISE 2 
As in EXERCISE 1, your task is to take a screenshot of your results obtained by running the 512 kbps 
Scenario, and include them in the final report. Once again, you are required to comment on the 
obtained graphs by answering the following questions: 
a) What are the new observed values of average utilization and average Response Time? 
b) How do these values compare to those collected in EXERCISE 1? 
 
 
 
 
Step 9: Set the link as T1 line and run the simulation 
 
In the third scenario, you will simulate a 1.544 Mbps (T1 line) download speed. For this WAN connection: 
 

• Duplicate the scenario as before and name it T1_Line. 
 

• Set the data rate for the WAN link to 1,544,000. 
 

• Rerun the simulation. 
 

• View the results for the link utilization on the WAN link and Response Time for the Researcher PC. 
 
 
 
EXERCISE 3 
As in earlier exercises, your task is to take a screenshot of your results obtained by running the T1 Line 
Scenario, and include them in the final report. You are also required to comment on the obtained 
graphs by answering the following questions: 
a) What are the new observed values of average utilization and average Response Time? 
b) How do these values compare to those collected in EXERCISE 1 and 2? 
 
 
 
 
Step 10: Compare Results 
 
Rather than viewing the results for the T1 link alone, let us compare the results of utilization and Response 
Times for all 3 scenarios. This will give us a broader picture of the effects of changing the data rate. 
 
1. Select Results. Under Results for select All Projects, and then check all three scenarios as shown below.  
 

 
 
2. To compare the utilization statistics, choose the following statistics: 
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3. Make sure to select Overlaid Statistics under Presentation. 
 
4. To compare the Response Time, choose PC2 Researcher -> Client Http -> Page Response Time 
(seconds) under Home Subnet: 
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5. Make sure to select average under Presentation. 
 
 
EXERCISE 4 
Once again, your task is to take a screenshot of the results obtained by performing Steps 10.1 to 10.5. 
After studying the obtained graphs, answer the following questions: 
a) How do the results of T1 scenario compare to the results of the earlier three scenarios? 
b) Which of the three WAN link options would you recommend to the family owning the network in 
question, and why? Justify your answer. 
 
 
 
So far, every exercise had step-by-step instructions. Now, here are some advanced exercises for you to run. 
 
 
 
EXERCISE 5 
In each of the three scenarios, many additional statistics - like the throughput [bps] and the queuing 
delay - are also being collected on the WAN link. View these 2 results for the three scenarios and 
prepare a brief report of your observation. 
 
 
 
EXERCISE 6 
Create a duplicate scenario. Change the data rate of the WAN link between the Router and the ISP 
to get a response time of under 1 sec. What WAN speed did your find to give this response time? 
 
 
 
EXERCISE 7 
(In this exercise, make sure you are back in T1_Line scenario.) 
There is continuous streaming between the music server and PC1 defined by a traffic demand 
object. You can view this object by selecting View → Demands → Show All in the menu. Try changing 
the download traffic volume for this demand. Specifically, change Traffic (bits/sec) attribute of the 
‘Music Server  PC1 Web Browser’ component of the Demand Object to the following values, 
respectively: a) 50,000 [bps], b) 250,000 [bps], c) 500,000 [bps]. Briefly describe the effect of the traffic 
volume increase(s) on the web response time for PC2 Researcher. (Take, and include in your report, 
all necessary screenshots of the obtained results.)  
 
 
 
EXERCISE 8 
Keep the setup parameters as in Exercise 7.c). Now, what would happen if 4 more PCs were added 
to the home network? To investigate this, create a duplicate scenario and name it 
4MoreResearchers. Select and Copy the Researcher PC. Then paste the PC 4 times into the home 
network field. (On every ‘paste’ operation, make two clicks – one on the copied icon, and the other 
on the 100BTSwitch. This will automatically create a connection between the new PC and the 
Home_LAN switch.) Run the simulation and view the web Response Time of PC2 Researcher. What 
did you find? 
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