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Chapter 0 
The Windows XP Environment 
 
The following chapter describes the Windows XP Environment. Since 
Windows XP, Microsoft has introduced two successors, Vista and now 
Windows 7.  The computing environment that you need to be familiar with is 
very elementary and general.  The descriptions here can be easily adapted to 
either Vista or Windows 7, and even to the Apple Macintosh environment, on 
the fly. 
 
Objectives 
This first chapter introduces you to the Windows XP® environment. It is strictly an 
introduction, which means that only the features that you need to understand and use 
frequently are covered. There are many more details and features that are not discussed. 
You should certainly consider buying one of the many trade books on Windows XP if 
you feel you need further help, and you should not forget to make use of the extensive 
on-line help provided with Windows XP itself. 
 
You should gain an understanding of the following topics: 

• Basic features of the Windows XP graphical user interface 
• Manipulation of windows 
• Use of menu commands 
• Navigating the file system 
• Managing your workspace 
• Using an email program 

 
These objectives are achieved through the completion of a set of exercises that illustrate 
the various features of the environment. 
 
Preparation 
To be able to complete this lab in a reasonable amount of time (roughly 3 hours) it is 
essential that you are properly prepared. You should read  

• All of this chapter 
• Any book on Windows XP available to you 
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Introduction 
In terms of using a computer the main thing to remember is it is merely a machine and, as 
with any machine, you are the operator. You must instruct it what to do, and if you give 
an incorrect instruction the machine will generally display a warning message or just 
ignore you.  
 
You must be attentive to the messages and signals displayed on the screen. Often you will 
be faced with having to respond to some question or event, and often such questions will 
effectively be "Do you really want to do that?" You will generally have the choice of 
answering Yes or No or Cancel, and you should make every effort to understand why you 
are being asked the question in order to choose the correct response. 
 
The computer screen often looks very complex, filled with icons representing commands 
or instructions to the computer, and subtle signals telling you what is happening. It is 
essential that you observe the screen very carefully. Although perhaps confusing at first, 
you will find that familiarity reduces the complexity of the interface.  

 
 

The following applies only to using a computing system on campus. 
 
Logging On 
When you sit down at the computer, you must logon. This means entering your user 
name (alternatively called your account name) and entering your password. The system 
verifies that these are correct and gives you access. 
 
This process should be straightforward. The logon panel will contain a text box labeled 
Account Name (or User Name or perhaps just Name) where you must type your account 
name, and a text box labeled Password where you must type your password. The 
characters you type for your password will not be displayed on the screen so take care to 
type your password correctly. If you make a mistake your attempt to logon will be denied 
and you will have to enter your account name and password again. 
 
Changing Your Password 
You may change your password using the Manage My Services program (which will 
appear on your desktop once you have logged on) but you cannot change your account 
name. Your password is like a key to your house - you should not give it to anyone else 
or let anyone else see you type it in. People who wish to break into someone's account 
have been known to go to great lengths to observe the keys pressed as someone types 
their password.  
 
 



CSE 1520.03  Glade Manual  
Computer Use: Fundamentals 
 
 
 
 
 

 

 0-3 

Forgotten Your Password 
If you forget your password you can reset it using the Manage My Services program. 
There will be a delay before you are able to logon to the Glade lab with your reset 
password, however. 
 
Elements of the Initial Windows Screen 
Once you have successfully logged on your screen should look similar to Figure 1.1. 
Some of the icons displayed on the desktop (as it is called) may be different from those 
shown in the figure but don't be concerned about that. In addition the bar along the 
bottom of the screen - called the Taskbar - may only display the Start item, but again this 
is not of concern. 
 
Figure 1.1 - the screen immediately after logon  
 

 
 
The icons on the desktop represent programs that you might want to use, and the 
Taskbar, via the Start button, provides an alternative way of starting programs. Most 
programs you need to use are not displayed on the desktop and hence you will have to 
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use the Start button to access them. We'll look at that shortly - but first let's see how to 
logoff from the Glade lab. This too is via the Start button. 
 
Logging Off 
Move the mouse across the desk so that the arrow on the screen points to the Start button 
in the Taskbar and click (press and release) the left mouse button. A menu of commands 
similar to that shown in Figure 1.2 will appear. One of the options at the bottom of the 
popup menu will be Log Off. You can simply click once on the word to execute the 
command - although do not do it right now unless you have to leave the lab. Click 
anywhere else in the screen to remove the Start menu. 
 
 
Figure 1.2 - the Start popup menu 
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The Mouse 
The mouse is used to move the pointer on the screen - as you have just found out. It has 
either two or three controls. It will always have two buttons which are referred to as the 
left and right buttons and some mice will have a third control, a little wheel between the 
buttons which can be used to scroll in the window of some applications.  
 
The mouse has many different functions depending on what program you are using, and 
its representation on the screen can have many different shapes according to its function 
too. The functions of the mouse can be broadly categorised as: 

• Changing the shape of windows and other objects 
• Specifying where characters typed at the keyboard are to appear 
• Selecting commands or control options (either by a single click or a double click) 
• Selecting text or objects that are to be changed by whatever command is 

specified next 
 
Carefully move the mouse so that the arrow points to the border of the Taskbar. Notice 
that it's shape changes from an arrow to a vertical line with arrows at each end. Press and 
hold down the left mouse button and move the mouse vertically on the screen. You'll see 
the Taskbar border increase in size as you do this. Release the mouse button and you'll 
find that you have reset the size of the Taskbar. Reset the Taskbar to its original size. 
 
This operation - pointing at something, holding the left mouse button down, and 
moving the mouse - is called dragging. Hereafter you will only be told to drag an object 
- the explicit steps will not be repeated. 
 
The File System 
There are two methods of accessing the files on the Glade system. One is by using the My 
Computer program represented by the icon on the desktop and the other is by using the 
Windows Explorer program. We will discuss Windows Explorer here, although you are 
free to use My Computer if you are already familiar with it. 
 
Launching Windows Explorer 
There are two convenient ways to access the Windows Explorer program.  The quickest 
way is to Right Click the Start button.  A popup menu will appear. Select the Explore 
option to launch the program.  The other method is generic for executing any program 
from the Start Menu.  Left Click on the Start button once again and move the mouse up 
the icons (notice how each is highlighted as the mouse passes over it) to the one called 
Programs. This option has a triangular arrow next to it indicating that another list of 
items will open up (see Figure 1.3). The list shown in the figure may not be exactly the 
same as the one you see on your screen. Move the mouse sideways into this new list of 
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options and up to the one named Windows Explorer and then click on this item. If 
Windows Explorer does not appear in the list, click on Accessories and locate it there. 
(Note: this is not Internet Explorer, which is a separate program.) A window similar to 
the one shown in Figure 1.4 will appear.  
 
The process of choosing a program to use from the Start/Programs menu is one you 
will perform very frequently. The steps will not be described again - we will simply say 
"launch programX from the Start/Programs menu", or perhaps just "launch 
programX". 
 
 
Figure 1.3 - the Start/Programs menu 
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The Explorer Window 
Figure 1.4 shows an example of the appearance of the Explorer window. The details of 
what you see on your screen may not be identical to the figure and in particular the right 
hand panel will not be the same, but that is not important. 
 
Firstly, move the mouse slowly across the borders of the window and notice that it's 
shape changes. Try dragging to resize the window. In particular place the mouse at the 
lower right hand corner and drag. Also position the mouse over the border between the 
two sections in the window and drag. Window resizing operations such as these are 
common to all windows. We will just say "resize the window" if it is necessary in 
future. 
 
Navigating the File Space 
Next observe the left-hand panel. It is displaying a list of names of the secondary storage 
devices attached to the computer and the folders stored on one of those devices. In the 
figure the folders on the C: device are displayed - this may not be the same as what you 
see.  You may choose a variety of ways to see your folders and files from the View menu. 
 

Figure 1.4 - the Windows Explorer window 
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Click on any of the little + symbols within a square to the left of a folder name (except 
not the one next to 31/2 Floppy (A:)) and observe that a new set of names appears and the 
+ symbol changes to a minus (-) symbol. These names are the names of folders contained 
within the folder next to the + symbol you just clicked. Click on the - symbol and the list 
of names disappears. You may have observed that when you did this the list of names in 
the right hand panel did not change. (Actually the Contents of display will change if you 
close a folder higher up the file hierarchy than the one currently displayed. Try clicking 
on the + next to My Computer for example.) Experiment further with this left hand panel 
until you are comfortable with opening and closing parts of the file system hierarchy. 
 
Make sure that you have a folder open in the left-hand panel that contains a list of other 
folders. Now instead of clicking on one of the + or - symbols, click one of the folder 
names. You should see that the contents of the right hand panel changes. It now gives a 
list of the folders and files in the folder you just selected. 
 
It is important to realise that the left hand panel displays only folder names while the 
right hand panel displays the names of both folders, and files contained in the folder 
selected from the left hand panel. 
 
Practice exploring the file system by clicking on the + and - symbols and selecting 
particular folders to display their contents. This is a very fundamental skill. In the 
future we will say things like "go to fileX in folderY" and we will expect that you can 
navigate through the file system. 
 
The Course Materials 
 
This section describes a process for copying files from one device to another, using how 
the course materials were once organized as an example.  Students used a computer in 
the Glade lab.  The Glade lab no longer exists, nor are the course materials located in 
such a folder. The course materials are now located on the course website and are copied 
to your own computer in a different way.  The process is still valid, only the example no 
longer applies. The process described is also assumes an environment in which you have 
to store the copied files in file space associated with a computer account and not the hard 
disk. 
 
There is one crucial area of the file system that you should examine even if you explore 
no further. This is the location of the course materials. These materials are stored in a 
space that your can Read, but your account cannot Write to this space. To save material 
you must use your personal filespace or a floppy disk. 
 
If it is not already open, open the folder (also called a volume or disk in this case) 
labeled Usr on Glade (H:) by clicking on the + symbol to the left of the name. You 
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should see a folder with the name courses. Open this folder and you should see further 
folders named cse1520 and cse1530, among others. Open the cse1520 folder and you 
should a folder named LabMaterials, as well as others  
 
You have now navigated your way to the place in the file system where course materials 
for CSE1520 are stored. You will frequently have to obtain files from the LabMaterials 
folder. Examine this area now. For example, open the LabMaterials folder, then click on 
the actual name Chapter4 (not the + symbol to the left of the name) to see the contents of 
the Chapter4 folder displayed in the right hand panel. 
 
You will not be given these detailed instructions again. In the future we will say "go to 
fileX from the Course materials folder", for example. 
 
 
Commentary 
The file space you have just been exploring is not contained on the secondary storage 
(hard disk) of your workstation. This collection of files is contained on the file server that 
is part of the local area network of the Glade lab. The computer that is the file server is 
physically located in a separate room and the data you have been exploring has been 
served to your workstation across the network. 
 
Access to these files on the file server is managed by Novell network operating system 
software which works in conjunction with the Windows XP operating system that is 
running on your workstation. This network is largely transparent to you - i.e. you do not 
need to be aware of it - although it is possible that your workstation may be slow at times 
because of data traffic congestion on the network. Such slowness is likely to be apparent 
when you launch a new program or open a new folder in a different part of the file 
system, for example. Both of these operations require data transfer over the network. 
 
The Command Menus of Windows Explorer 
Every program has a set of pulldown command menus listed across the top of the 
window. In the case of Windows Explorer the menus are File, Edit, View, Favorites, Tools 
and Help. It is essential that you familiarise yourself with the command menus whenever 
you use a new application. (Notice that we are using the words "program" and 
"application" interchangeably - they mean the same thing at this stage.) Some programs 
provide alternative ways of issuing the same command - one way might be through the 
command menus and another might be through some kind of tool bar for example. 
Familiarity with how to control an application is crucial to its use. 
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Often the commands available in a menu change depending on what is currently selected 
in the application window. This is a crucial point and whenever faced with a new 
application you should be very attentive in exploring the various commands. 
 
The File and Edit menu 
Every application has File and Edit menus. Generally the File menu contains commands 
for opening, closing, and saving a file, for closing the application window or exiting the 
program, while the Edit menu has commands for cutting, copying and pasting selections 
of data. 
 
First, make sure you have your home folder selected. Your home folder is where you 
have write permission (i.e. the freedom to change things by creating new folders and files 
or deleting folders and files). The operations discussed below cannot be performed 
unless you are using your home folder. 
 
Creating a New Folder 
With your home folder selected, click on the File menu. The menu commands shown on 
the left in Figure 1.5 should appear. Move the mouse to position the cursor over the New 
command and the submenu shown on the right in Figure 1.5 appears.  
 
 
Figure 1.5 - the File menu and the File/New menu when no file is selected 
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Move the mouse to click on the Folder command. You will see a new entry in the 
Contents panel named New Folder. Generally you don't want the name for a folder to be 
New Folder, so while the name is highlighted you can simply type a new name - in this 
case please type Lab4 - and then press the Enter key. 

 
This is an operation you will want to perform quite frequently - select the folder that 
you want to contain the new folder, choose File/New/Folder from the menu commands 
and type an appropriate name. 
 
Copying a File 
We named the new folder Lab4 because we want to demonstrate how you can copy files 
from the Course materials to folders in your own directory space when you need them. 
The copy operation can be used to copy a file from any folder to any other folder, or to a 
floppy disk. 
 
There are a number of ways to do this copy operation. We'll outline two of them. The 
first method uses the Copy and Paste commands from the Edit menu. The second method 
introduces the use of the right-hand mouse button to pop-up a command menu. 
 
Go to the Chapter4  folder of the lab materials and select the file lab4_ex1. Click on the 
Edit menu and choose Copy. Nothing appears to happen, but in fact something very 
important has happened. A copy of the complete file you selected has been placed in an 
area of the computer's memory called the clipboard. The Edit command of every 
application allows you to copy something you have selected (a section of text or an image 
for example) to the clipboard. The data you selected remains in the clipboard even after 
you paste it. It remains until you select something else to copy, thereby replacing what 
was in the clipboard. 
 
Now select the Lab4 folder in your home directory and choose Paste from the Edit 
command. You should see a file appear in the contents of your new Lab4 folder with the 
same name as the one you just copied. 
 
Return to the Chapter4 folder in the Course materials and select the file named 
lab4_ex2a. Now click the right-hand mouse button while the cursor is pointing directly at 
the file name. The command menu shown on the left in Figure 1.6 should appear. If you 
have moved the mouse away from the file name the menu shown on the right in Figure 
1.6 will appear, and you should then simply click anywhere outside of the menu and 
reselect the file. Choose Copy from the correct menu. 
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The pop-up menu that you see following a Right-Click (right-hand mouse button click) 
depends on the position of the mouse pointer - as you have just seen in the previous 
paragraph. Take a moment to move the cursor to different places on the screen and right-
click. To avoid executing a command just left-click anywhere outside of the menu that 
appears. 
 
Return to your home directory and select the Lab4 folder, use the right mouse button to 
pop-up the Contents panel command menu (the cursor must be in the Contents panel) and 
choose Paste. You should see the file you selected appear in the contents list of the Lab4 
folder. 
 
Figure 1.6 - pop-up menus using the right-hand mouse button in Windows Explorer 
 

 

 

 
 
Renaming a File or Folder 
This operation can be done in a number of different ways too. Having selected the file or 
folder to be changed you can choose Rename from the File menu, right click while 
pointing at the file or folder and choose Rename, or simply click a second time on the 
name itself. In all three cases the name becomes selected as text which you can then 
retype as the new name or edit to insert or delete characters from the existing name. 
 
Select the file lab4_ex2a and then click on the name itself a second time (not on the 
icon). You should be able to see the cursor blinking at the end of the highlighted name. 
We'll change the name to my_ex2a. You could simply type all of these characters, but to 
demonstrate the nature of editing text we'll do it a little differently. 
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Position the mouse over the file name and you'll see the cursor change to what is called 
an I bar. This symbol for the cursor is used whenever text editing is required - most 
commonly in a word processor, but also in cases like this.  Move the I bar to just after the 
character "4" then click and drag across the characters lab4. You should end up with the 
file name looking like this: 
 
 
When next you type something only the selected characters will be replaced - so now 
type my and then press the Enter key. 
 
Deleting a File or Folder 
You don't actually want these files, nor the folder, so you decide to delete them. Simply 
select the folder and choose Delete from the File menu. The dialogue panel shown in 
Figure 1.7 appears and you can answer Yes. 
 

Figure 1.7 - the Confirm Delete panel 

 
 
Note:  Figure 1.7 and 1.8 refer to ‘Lab3’ and lab3_ex1.xls and lab3_ex2.xls.  Substitute 
‘Lab4’ and lab4_ex1.xls and lab4_ex2a.xls. 
 
This has not yet permanently removed the folder and files. They are in fact stored in the 
so-called Recycle Bin and can be retrieved if necessary. Data in the Recycle Bin still uses 
up your disk space. If you try to delete files because you have filled your disk quota 
(about 50Mbytes) you will actually have to empty the recycle bin as described next 
before the space you are intending to free up is actually available. 
 
 
 
 
 
 

Selecting part of a file name to change: 
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Figure 1.8 - the Recycle Bin window 
 

 
Double click on the Recycle Bin icon on your desktop and the window shown in Figure 
1.8 appears. If you needed to you could select one of the files in the recycle bin and 
delete just it, leaving the others there to be retrieved at some later date. You would do this 
by selecting the file and choosing Delete from the File menu. In this case we can safely 
delete all of the files by choosing Empty Recycle Bin from the File menu. A confirmation 
panel appears to which you can respond Yes. 
 
The View Menu 
The File and Edit menus are common to most applications, as is the Help menu usually. 
The other two command menus in Windows Explorer are unique to this program. The 
View menu simply allows you to change how files and folders are displayed in the 
window and how the window appears. You can experiment with the commands there. 
Try turning the Toolbar and Status Bar off and on again for example. Also see what 
Large Icons, Small Icons etc do to the display. You can set the Explorer window to 
whichever appearance you find most convenient. 
 
The Tools Menu 
The Find command is a very useful one available from this menu (Figure 1.9). As the 
name suggests it allows you to search for a file or folder if you don't know where it is. 
Naturally you do need to know the name or at least part of it. The Find command is also 
available from the Start button. 
 

Figure 1.9 - the Tools/Find menu of Windows Explorer 
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Click on Files or Folders… in the Tools/Find menu, since that is where you want to 
search and you'll see a window similar to Figure 1.10 appear. You first need to specify 
where to search, which you can do by making a selection from the pulldown menu 
associated with the Look in: box. The pulldown menu is activated by clicking on the 
down pointing triangular arrow at the right end of the Look in: box. The pulldown list you 
get will not be identical to that shown in the figure. Generally you will want to search the 
(F:) drive so select it now and then type the file or folder name in the Named: text box. 
(First click in the Named: text box in order to position the cursor there.) For this 
demonstration type Lab4, and then click the Find Now button. 
 
Figure 1.10 - the Find files window 
 

 
 
You should find a list of 3 files the names of which include the characters Lab4. If you 
use the View menu and choose Details you will see the folder that contains the files and 
hence be able to navigate to that folder in the future. You can also simply open one of the 
files directly from this Find window. 
 
The Toolbar 
Most applications have one or more toolbars that usually appear just below the menu 
commands. (You can often reposition the toolbar, but Windows Explorer doesn't allow 
that.) The toolbar is usually just a quick way of performing common operations that can 
also be done via the command menus.  
This is the toolbar for Explorer: 
 

 



Glade Manual  CSE 1520.03 
  Computer Use: Fundamentals 
 
 
 
 
 
 

 0-16 

 
Slowly move the mouse across each object pausing at each for a few seconds until a brief 
message outlining what the tool icon does is displayed. There is no need to actually 
perform any operation (i.e. don't click) - just observe that they duplicate many of the 
things you have done using the command menus. 
 
 
Using Other Programs 
 
Launching Programs 
There are two common ways of launching (starting or beginning to use) an application. 
One is to find a file that was previously created using the program in question and double 
click on that icon/file name. Another is to use the Programs menu from the Start button. 
When you are using a program for the first time this latter method is your best alternative. 
A third approach is to find the application file using Explorer and double click on the 
application itself. 
 
You'll find the program Microsoft Word in the Start/Programs menu. Click on it and 
you'll see a window for this word processor appear. You should also find in the 
Start/Programs/Accessories grouping a program called Paint. Click on it as well. 
 
You now have three programs running - Windows Explorer, Microsoft Word, and Paint. 
Observe that the taskbar at the bottom of your screen displays buttons for the three 
programs. Probably the screen is quite cluttered, and while you might want to work with 
all three programs you can only actually use one at a time. 
 
It is important to realise that launching a program means that the instructions that 
constitute that program are loaded from the secondary storage (the hard disk) into the 
computer's main memory (the RAM). In this case the instructions for all three programs 
reside in the computer's main memory at the same time. 
 
Working with Multiple Applications 
In order to avoid confusing clutter on the screen when you want to work with multiple 
programs it is possible to minimise a program's window and reactivate it later when you 
need it. 
 
Taking the Paint program as an example, click on the minimise button in the right-hand 
of the title bar for the window: 
 
 

The minimise button: 
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The window disappears. It can be retrieved by clicking on the Paint button in the 
Taskbar. Any application can be minimised in this way in order to tidy up a confusing 
desktop. All of the programs are still running when they are minimised - i.e. they are 
occupying space in the main memory of the computer and ready for use whenever you 
need them.  
 
Switching Between Applications 
If you have two or more application windows visible on the screen at the same time it is 
important to realise that only one can be the active window, i.e. the one that you are 
currently using. 
 
At the moment you probably have windows for the applications Windows Explorer, 
Microsoft Word, and Paint visible. Observe that there is one lying on top of the others 
and that the title bar of that window is highlighted. This is the active window. It 
represents the program you are currently using. 
 
Click anywhere in one of the other windows and you'll see that window come to the 
foreground. It is now the active window. 
 
Sometimes it is possible that a window is completely obscured by another larger window 
and you might forget that it is there. You can always tell which applications you have 
launched by examining the taskbar at the bottom of the screen. 
 
Saving your Work after Using an Application 
Make sure the Microsoft Word application is the active one and type a few words - 
anything you like. This is now the start of something you might want to save - to come 
back to work on later, for example. In later lab work you will usually want to save your 
work after using the Microsoft Excel application. The process is identical to what we are 
about to describe. 
 
Go to the File menu and choose Save As…  The dialogue panel shown in Figure 1.11 will 
appear. The purpose of this panel is for you to specify a folder in which to store the file 
and to specify a name for the file. There are probably no folders in your home folder yet 
so we won't do that part. If there were any folders they would be listed in the empty text 
box area and you could double click on one to open it in order to store the file there. 
The file name will currently be specified as part of the text you just typed and no doubt 
you should change this. The file name should be highlighted (if its not make sure you 
select the whole of the file name first) so just type a new name - test_lab1 will do for 
example - and click on the Save button. If you now examine your home directory using 
Explorer you should see this new file in the contents panel. 
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When you work on this file again and come to save it you will generally not use the Save 
As… command. Typically you will only use Save As… after creating a new file.  
 

Figure 1.11 - the Save As dialogue panel 
 

 
 
You would use the Save command from the File menu instead, which will simply save 
your changes to this file by updating (overwriting) the existing file. The old version of the 
file will be lost, of course, so if in fact you wanted to retain the old version you would 
have to use Save As… and specify a new name. 
 
The file has been saved in your directory space on the Glade file server. It is not saved on 
the hard disk on your workstation (In fact you are not able to save anything to the hard 
disk on the workstation.)  
 
Copying Files to a Floppy Disk (or Flash drive) 
It is possible that you might want to make a copy of a file on a floppy disk to use on your 
computer at home, for example. This is easily done by inserting a floppy disk in the slot 
on the computer and following the instructions already given in the section on copying 
files. Instead of choosing a different folder as the place to paste the file you will choose 
the floppy disk, which appears as shown in left-hand panel of the Explorer window. 
 

The floppy disk icon: 
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This can easily be adapted to copying files to a flash drive.  Insert the flash drive into the 
appropriate slot on the computer and perform the same operations as described above, but 
use the flash drive icon in place of the floppy disk icon. 
 
Using Windows Help 
There are many more details of the Windows environment that you should learn about. 
One of the best ways is to use the online help when you run into something you don't 
understand or when you don't know what to do.  From the Explorer window click on the 
Help Topics command in the Help menu. The window shown in Figure 1.12 appears, and 
you should spend some time familiarising yourself with it now, so that when you need to 
use it you are able to easily. Most other applications you use will also have extensive on-
line help. It is usually a very good idea to explore the help documents whenever you 
begin to use a new application. 
 
Figure 1.12 - the Windows XP Help window 
 

 
 
 


